Stadium Server R App

What is your experience with the stadium server app?

  • I am using it with no problem

    Votes: 4 44.4%
  • I tried but failed to get it work

    Votes: 1 11.1%
  • It looks way too complcate for me

    Votes: 4 44.4%
  • I am using it but it is buggy

    Votes: 0 0.0%

  • Total voters
    9

dinei

Youth Team
Do you mean the the exported_db folder was not empty in the last version of the server I shared. I need to check that, but that surprises me.
Indeed the doesn't need you to add the stadium from your db to the map file.
But the the app doesn't read the IDs it get them from the db files from the exported_db folder. Stadiums.txt file.
Your exported db folder comes empty.
What I meant was, It wasn't necessary put the Stoke and Bournemouth in the map_stadium.txt, because they have yours onws stadium in the db.
What I don't uderstand is: Stoke stadium is id331, Bounemouth is id348 and the tool try to load the id267. There's no stadium 267, even in my db or stad_source_files.zip.

Bouner.jpg
stoke.jpg
 

Papinho81

Youth Team
That's strange because the app can't invent an ID that's not in the exported_db files. It can pick a wrong one, that's possible but not invent one. May be in your map_stadium file. ?
 

dinei

Youth Team
I don't think so. Look at my files:
 

Attachments

  • map_stadium.txt
    22.1 KB · Views: 51
  • stadiums.txt
    30.8 KB · Views: 50

dinei

Youth Team
I think I found the bug's reason.
The three clubs, Bornemouth, Stoke and Hull didn't have the stadium name assign in my db, only the stadium model. I put the stadiums names and now the stadiums work very well.
Sem título.jpg
 

Papinho81

Youth Team
Glad you found a fix! This entry feels the stadiumassignements.txt table.
Normally it should have worked without it as long as the two names of the stadium match in the stadium section of CM16 (Edit: but for Britannia they didn't match when looking at your picture above).
Also I really don't get why the tool thrown at you that imaginary ID. I checked your files, the ID is absent from both. I tried to reproduce it at home but it works like it should. Bizarre.
 
Last edited:

dinei

Youth Team
I was able to add more tha 450 stadium with your tool and works perfectly! I haven't words to thank you enough my friend.
Is it possible to do something similar with scoreboard?
 

Papinho81

Youth Team
I was able to add more tha 450 stadium with your tool and works perfectly! I haven't words to thank you enough my friend.
Is it possible to do something similar with scoreboard?

Thank you very much for your kind words my friend, I really appreciate.

The problem with scoreboard is that they would have to work with tournements ids and I didn't find a way to access it from a sceenshot.
 

dinei

Youth Team
Thank you very much for your kind words my friend, I really appreciate.

The problem with scoreboard is that they would have to work with tournements ids and I didn't find a way to access it from a sceenshot.
I understand mate!
I appreciate your efforts!
 

elchachocoudet

Club Supporter
Hello Papinho,

First of all thank you for such a great tool. I'm having some issues to inject new stadiums. My specs:

* FIFA 16 (legit - vanilla - all official updates)
* Windows 8.1 x64 bits
* R Version 3.6.2
* Python 3.8.5

I run R from the Rgui.exe that is in C:\Program Files\R\R-3.6.2\bin\x64

I installed libraries, everything seems to be ok. I can run the Stadium Server, the black python window is in background. That's perfect. I assigned a new stadium by choosing a team. Then I run the game and I run stadium server (it's says is running so that part is ok).

I choose the teams, in the kick off screen I press '$' and I can hear the first sound. Wait a couple of minutes, I don't hear the second sound. My computer is fast, so loading times shouldn't be a problem (i5 9600 + 16 gb ram + RTX 2060 + SSD disks)

When I start the match, it shows the default stadium "Tierra de Campeones - Dep. Iquique - Chile" instead my stadium. I guess because it's not loaded.

In the R console it shows the following error:

"
Error in browse_game() : object 'continue_process' not found
Error in data.frame(..., check.names = FALSE) :
arguments imply differing number of rows: 2, 0
Error in if (nchar(stad_name_pic) == 0) { :
missing value where TRUE/FALSE needed
In addition: Warning messages:
1: In .Internal(get0(x, envir, mode, inherits, ifnotfound)) :
closing unused connection 3 (C:/Stadium Server/Stadium_Server_Package_Pap_v1.5/Stadium_Server_Package_Pap_v1.5/Stadium Server Package v1.5 AIO/Stadium Server R App/exported_files_DB/teams.txt)
2: In for (field in elNames) envRefSetField(.Object, field, classDef, :
closing unused connection 3 (C:/Stadium Server/Stadium_Server_Package_Pap_v1.5/Stadium_Server_Package_Pap_v1.5/Stadium Server Package v1.5 AIO/Stadium Server R App/exported_files_DB/teamstadiumlinks.txt)
Error in if (nchar(stad_name_pic) == 0) { :
missing value where TRUE/FALSE needed
Error in data.frame(..., check.names = FALSE) :
arguments imply differing number of rows: 2, 0
Error in if (nchar(stad_name_pic) == 0) { :
missing value where TRUE/FALSE needed
In addition: Warning messages:
1: In for (what in notDone) installClassMethod(get(what, envir = [email protected]), :
closing unused connection 4 (C:/Stadium Server/Stadium_Server_Package_Pap_v1.5/Stadium_Server_Package_Pap_v1.5/Stadium Server Package v1.5 AIO/Stadium Server R App/exported_files_DB/teamstadiumlinks.txt)
2: In for (what in notDone) installClassMethod(get(what, envir = [email protected]), :
closing unused connection 3 (C:/Stadium Server/Stadium_Server_Package_Pap_v1.5/Stadium_Server_Package_Pap_v1.5/Stadium Server Package v1.5 AIO/Stadium Server R App/exported_files_DB/teams.txt)
Error in if (nchar(stad_name_pic) == 0) { :
missing value where TRUE/FALSE needed"

Can you figure which is the problem?
Thanks!
 
Last edited:

elchachocoudet

Club Supporter
Installed everything again. This time tried using R 3.6.3. Still having this issue:

Error in if (nchar(stad_name_pic) == 0) { :
missing value where TRUE/FALSE needed


I hear the first sound but not the second one.

My hunch is that the problem is that install.packages("gWidgets2RGtk2") it's not working becaue it was removed from the Cran repository too
 

Papinho81

Youth Team
Installed everything again. This time tried using R 3.6.3. Still having this issue:

Error in if (nchar(stad_name_pic) == 0) { :
missing value where TRUE/FALSE needed


I hear the first sound but not the second one.

My hunch is that the problem is that install.packages("gWidgets2RGtk2") it's not working becaue it was removed from the Cran repository too
Sorry for the late answer.
It could be. Do you get an error when you click the browse button?
Or you can type library(gWidgets2RGtk2) to check if it is installed correctly.
If it is try to send the screenshot of your kickoff hub. To do so just don't click run, take the screenshot. Go to the app folder and upload it here.

I have not much free time. I won't be able to help you more before tonight.
 
Last edited:

Syphon-x

Youth Team
@Papinho81 Hi Papinho, I discovered your thread these days and your App seams to be very interesting. I returned once more to play for a while Fifa 16 for well known reasons. You mentioned in one of your earliest posts a big advantage of your app is to play with different game versions of Fifa 16. Can you tell me where I can find or where I can download different exe Versions of Fifa 16? I am curious how does the game feels like. To be honest, the last reason for me to take another round with FiFa 16 is the gameplay. Of course I already tried near all gameplays that are released, but it´s not the same like Fifa 20, which I don´t think it´s very good gp. Only with patched GP it is a good game. So, after I modded Fifa 16 the last days it´s time to care about the gp. And that´s why I ask you. Of course I wanna try out your app too when I should be able to grab another exe version. Llast but not least, many thanks for your effort and work you put in this promising app. I appreciate if the modding of Fifa 16 will be continued.
 

Papinho81

Youth Team
@Papinho81 Hi Papinho, I discovered your thread these days and your App seams to be very interesting. I returned once more to play for a while Fifa 16 for well known reasons. You mentioned in one of your earliest posts a big advantage of your app is to play with different game versions of Fifa 16. Can you tell me where I can find or where I can download different exe Versions of Fifa 16? I am curious how does the game feels like. To be honest, the last reason for me to take another round with FiFa 16 is the gameplay. Of course I already tried near all gameplays that are released, but it´s not the same like Fifa 20, which I don´t think it´s very good gp. Only with patched GP it is a good game. So, after I modded Fifa 16 the last days it´s time to care about the gp. And that´s why I ask you. Of course I wanna try out your app too when I should be able to grab another exe version. Llast but not least, many thanks for your effort and work you put in this promising app. I appreciate if the modding of Fifa 16 will be continued.

I will ask the mods if I am allowed to share them but I can't hardly see any problem with that as if you don't own the game, you won't be able to launch those exe anyway.

As for the tool, there is a small update pending tonight.
 

Papinho81

Youth Team
The last version of the stadium server is available here:
http://www.mediafire.com/file/lbuqtzlsonc92jx/Stadium_Server_Package_Pap_v1.6.rar/file


### List of changes:

v1.6:
- Improved the ability of the App to discriminate text from the taken screenshot
- The Browse function now immediately save the provided path where before closing the app and reopening it was necessary


General:
- The manual (available in the AIO) now provide the link toward the last version of R (v3.6.3) compatible with the tool. R v4 is not compatible with the tool.
- The manual now provide the updated download link for the stad_source_folder containing all the default game stadium files which are mandatory for the app.
- The gWidgetstcltk library install problem has been fixed.
 
Last edited:

Papinho81

Youth Team
It looks like some libraries have been removed from the net. It doesn't affect old users that have the tool working. But new user will be unable to correctly install the tool.
I will share a new version in couple of days with a solution
 

Papinho81

Youth Team
Small update to fix a problem with R libraries problems during first install.
Users that have already installed the tool were not affected.

 


Top