How to deal with increasing slowness and error rates in game


Club Supporter
I have had the same problem for ages (I'm playing Fifa 14): players starting to move and react to my moves on the controller slowly, extremely high rate of passes going wrong, and so on. It usually starts getting worse the longer I am playing.

First I thought it was a performance problem. After I had got myself a new gaming laptop I found that the problem still persisted.

To me it seems like it's got to do with timing and resource allocation somehow. Windows is not a real time operating system after all, and probably the way things are implemented in the game is part of the problem, too.

I tried changing the game's performance parameters in the settings, but no success. I then started experimenting by using the sliders for user and cpu attributes in the gameplay settings, in particular, tried reducing the error rates in my passing and first touch errors, also increased speed and acceleration of my players. This gave me kind of an advantage, but only while the game was behaving well; I'd still get into this annoying "grease" mode (only I could sometimes save myself by using my players' speed advantage).

I have now found a workaround that brings the game back to normal for me: I found that if I decrease the CPU players' speed and acceleration to, say, 47%, then my players don't get into this greasiness thing. Also I have set the game to "slow" (just for completeness, I've had it on "slow" before, so that was not the change that made it work). Strange, but true, probably because the way it is implemented, my interaction with the gamepad and the game's reaction on it gets more resources this way and will be processed normally by my machine.

I have been using this setting for several days now, and it has been fun ever since then. Not because my players are faster than the CPU's players (actually, before I had increased my players' speed and acceleration to 60% and the game still sucked), but because the game feels responsive and just playable again.

Just thought I'd share this as I've seen that many others had the same problem.