FIFA 14 Stadium Server

shawminator

Reserve Team
hibee72;3699603 said:
Hi Shawminator!
First of all, thanks for all your efforts and for your Scottish stadia. ;-)
I took a look to your Stadium Swapper to see how it works (and for me it works) and I saw that before the game starts the stadium files are converted to the ID that the stadium has in the DB in the TEAMSTADIUM table. I suppose your tool doesn't change the DB, just changes the graphics files in order to work with the current DB.
Then I took a look of your STADIUMGBD folder to understand how your new tool works. I was surprised that, in every stadium folder, stadium files are reported twice with the 158 and 196 id. Your tool simply renames the stadium folder in DATA, but if the stadium files contained in the subfolders are not renamed with the ID the team (or the tournament) has in the DB, your tool will never work.
This is what's happening on my PC: of course I may think I misunderstood something in the installation/configuration process. What should I do to make it working properly?

Extra question: could you please make Easter Road stadium too? ^_^

sorry, i released the tools in a bit of a rush,
all file in the stadiumgbd folder should be id 158, if there are any for 196 please delete them

how the tool works is that it forces the game to use id 158 instead of the id from the db, thats why all id's in the stadiumgbd folder are 158

so you are half right with the renaming of the stadium folder to Data, but it then needs the id of 158 (expect for previews) as the tool then forces the game to use stadium 158,

first thing to do is on the tool go to file>delete extra files.
then check the stadiumgbd folder, if there are any files with the id 196 please delete them,

also what version of the tool are you using?
hope that makes some sense


EDIT:-
i have reuploaded both versions of the tool, the stadiumGBD was wrong, i have deleted all files with the id 196 leaving only 158
 

hibee72

Youth Team
I'm using the Origin version. I checked my FIFA.EXE version and it's 1.7.0.0 so I guess it should be correct.
I'll try to follow your tips and then I'll let you know if it works.

For now the tool doesn't force anything: I tried changing manually the 158 ID with the one of the stadium set in the DB and then it works.
The other problem is that, after a game, the stadium folder that's named "DATA" is not named back with the stadium name. I had to rename it manually.
Maybe your tool is just close to the goal but it needs some little patching: you may assign to the stadium the ID in the DB (you can get it from the TEAMSTADIUM tables) instead of taking the 158, then you should rename correctly the stadium folder (you may choose to make a temp copy of the stadium folder, rename it as "data" and then delete it when exiting from the match GUI).
I know it seems so easy to say but it's harder to do: I was a programmer and I've got no idea of the code you used to build up your tool, but if you could write such a nice tool I guess you've got the numbers! :)

P.S.: any news about Easter Road? :P
 

hibee72

Youth Team
I must apologize, mate: I cleaned up the folders as you suggested me and now it works like charm! ^_^
There was something wrong in the FIFA14MOD settings: now it's perfect!
 

fakefisher

Youth Team
finally it work :}

but the tool cant automatic change the stadiums ,I must manually press the F5 button 6 times when I saw the stadium preview stage,
do I have to install the .net framkwork 4 for 32bit windows7?

also I try to setup a new stadium according the instruction, and it work .

if you use 3dm-loader version

1.make sure you download the 3dm crack pack NO.2(for fifa14v1.3)
2.delete the extra stadiums files like id196's in StadiumGBD folder
 

Leo_95

Reserve Team
Not working in career mode for me, I made all team assignments and it works alright in Friendly mode.
 

shawminator

Reserve Team
Leo_95;3699940 said:
Not working in career mode for me, I made all team assignments and it works alright in Friendly mode.

Are you using the 3dm launcher version of the tool. I tested it yesterday using the latest one from skidrow which is update 2 fifa14 v1.3 and had the same issue. I only installed that update yesterday but it was working fine with update 1. Ill check today to see if anything has changed.

Can anyone cofirm they have the origin version working fully in all modes?

.net 4 minimum must be installed for the tool to work
 

hibee72

Youth Team
Hi Shawminator,

I tested it yesterday on a Origin platform:

In friendly mode the home assignment of the stadium is OK.

Vice versa, it doesn't work in tournament mode (I played a Scottish Cup but there was no stadium changing in the semifinals and finals). I was playing offline: could it affect something?
Maybe there's something wrong in the configuration like it was for friendlies: I've already cleaned up the folders as you suggested yesterday, but it didn't worked. How could I fix it up?

I couldn't test it in career mode yet. I'll let you know asap.
Thanks again.
 

shawminator

Reserve Team
hibee72;3700469 said:
Hi Shawminator,

I tested it yesterday on a Origin platform:

In friendly mode the home assignment of the stadium is OK.

Vice versa, it doesn't work in tournament mode (I played a Scottish Cup but there was no stadium changing in the semifinals and finals). I was playing offline: could it affect something?
Maybe there's something wrong in the configuration like it was for friendlies: I've already cleaned up the folders as you suggested yesterday, but it didn't worked. How could I fix it up?

I couldn't test it in career mode yet. I'll let you know asap.
Thanks again.

you only need to be offline for the friendly game for the server to work
all other modes work ok with either online or offline.
i tested the version i uploaded and it was successfully working in both career and tournament mode,
as you can see from the pic it has assigned Hampden for the Scottish cup semi final which has round id 1248, u can tell it has worked for two reasons the previews are shown ingame and the name hampden park - scottish cup appears just above the stadium server enabled on the tool



Do you use any patches ie modding way etc....?
if so u may need to check in cm14 that the tournaments and id are still the same, and if not alter the ini file to match ur db

it seems as though for some reason the trigger is not working to kick off the process.
 

shawminator

Reserve Team
Leo_95;3700204 said:
Yea, I use 3DM Update 2 indeed.

ive checked the code and it seems i had the wrong memory address for the tournament id,

heres the new exe which i have tested with the update 2 fifa14.exe v 1.3 and 3dm loader

DOWNLOAD

replace the exe file in the game folder with the new one and test tournanemt and career mode
 

hibee72

Youth Team
My FIFA is basically patched with the ModdingWay Patches, which are basically graphic patches even though I use a DB featuring the FIFA World Cup for Clubs. By the way, Scottish Cup I guess it wasn't affected.
Your screenshot is similar to mine, except my StadiumServer can't get the COMP_ID and doesn't show the current stadium in the bottom line. I guess I made a mistake in the tool configuration but I just can't get it. :/

I guess it has something to do with the MW Patches: surely the tournament ID is taken from the settings.txt file. Since the MW patches feature several DBs there are many settings.txt files where you should point at. So it probably depends what settings.txt file is taken as reference by the StadiumServer...
 

Leo_95

Reserve Team
shawminator;3700724 said:
ive checked the code and it seems i had the wrong memory address for the tournament id,

heres the new exe which i have tested with the update 2 fifa14.exe v 1.3 and 3dm loader

DOWNLOAD

replace the exe file in the game folder with the new one and test tournanemt and career mode

It works alright now mate, thx a lot
 

fakefisher

Youth Team
+1

finally hear the exciting beep when play career and tournament.
but friendly still not work besides manually press F5

I use 3dmloader Update 2
 

fakefisher

Youth Team
may I report a bug , the tool seem to not support the letters besides english's .

such as
481 = Spain - Estadio Ramón Sánchez Pizjuán,Sevilla FC,5,1,0
1860 = Spain COLISEUM ALFONSO PéREZ-GETAFE,5,1,0

this string will not take effect and cause error.
 

shawminator

Reserve Team
fakefisher;3701546 said:
may I report a bug , the tool seem to not support the letters besides english's .

such as
481 = Spain - Estadio Ramón Sánchez Pizjuán,Sevilla FC,5,1,0
1860 = Spain COLISEUM ALFONSO PéREZ-GETAFE,5,1,0

this string will not take effect and cause error.

Yes sorry, should have said it is English characters only
 

hibee72

Youth Team
I'm sorry but I just can't make it working in tournament mode (either in career or not).

If I match a team with a stadium assigned, in League or Friendly matches, the tool works! :)
If I have to change stadium for a tournament (national or international cup) it doesn't work. I noticed that my StadiumServer NEVER evaluates the COMP_ID (that I took from the DB but I read with CM14 in order to properly set up the COMP section of the SETTINGS.INI.

Could you please tell me where your program takes the COMP_ID value? Maybe there's something in my FIFA setup that I could change to make it work. I think it should take it from the FIFA 14\Game\dlc\dlc_FootballCompEng\dlc\FootballCompEng\data\compdata\settings.txt file: am I wrong?

Then, what is the exact format of a COMP statement entry?
COMP_ID = [stadium folder name],[police code],[pitch mowpattern], [nets] ?
I noticed that there was some more stuff on you COMP entry line (the string "Scottish Cup Semifinal (Scotland)"): is it necessary or is it just a comment line?

Still thanks a lot for your efforts, support and patience! :)
 

shawminator

Reserve Team
In the comp setup the last is just a comment, so u know what round and cup it is. My tool reads the memory for the comp id. So unless ur game uses a different address it should work. Can you tell me what patches and stuff u have installed. Do u have a quick start option installed? Also can i double check what version of the tool u are using?
 

fakefisher

Youth Team
another issue is :

when the tool change a folder to "data",it won't be "recover" when the next assignment.
during this period the user want to add a new stadium, select "rename all stadium id" will cause a error.

plus:I think support all charactors wil be betther

thanks for your continously effort!
 

shawminator

Reserve Team
fakefisher;3701740 said:
another issue is :

when the tool change a folder to "data",it won't be "recover" when the next assignment.
during this period the user want to add a new stadium, select "rename all stadium id" will cause a error.

plus:I think support all charactors wil be betther

thanks for your continously effort!

There's two ways of resetting the data folder
1. Closing the tool and restarting it.
Or
2. Pressing f6, which reset the data folder to the stadium name as long as u have finished the match in which the stadium was being used.

I'm unsure as how to add character support for different languages but i will look into it
 

hibee72

Youth Team
shawminator;3701646 said:
In the comp setup the last is just a comment, so u know what round and cup it is. My tool reads the memory for the comp id. So unless ur game uses a different address it should work. Can you tell me what patches and stuff u have installed. Do u have a quick start option installed? Also can i double check what version of the tool u are using?

I've installed the ModdingWay patch suite and some other graphic patches (Fifa Revolution by Scouser) but I am sure they do not affect the behaviour of the game, except for graphics (kits, flags, scarves, etc.).

I don't think to have a quick start option: I've got just a multi-Language patch (my FIFA is an Italian version one but I'm used to play the English GUI and commentary version because I am a Hibernian FC fan).

My StadiumServer.exe is version 0.7.0.0 (278 Kb).
 


Top